Connect my mobile

About Forums Forum Connect my mobile

Tagged: , ,

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #958

    First of all the idea of breakout is brilliant but if you can give me an help it would be great. I run the hello world example on my pc browser and it works perfectly but I can’t manage to connect my phone. I’ve connected on the same wifi network the pc and phone, I have 4.3 Android Jelly Bean, I’ve tried the newest google chrome/ fire fox and internet explorer. I’ve changed in the code of the hello world instead of host to “my ip address” and I still can’t see the page on my phone. Can you please tell me what I need to change please?




    I am having the same problem. I downloaded Breakout v.0.3.2 and I am unable to connect my Android phone. I am just trying to run the Hello_world example, I changed the host to my laptop’s IP address and when I run the example it works fine on my laptop (that is where the Breakout Server is running) but then on my Android phone, using Chrome, I go to and enter in the same IP address then hit enter on my device keyboard, nothing happens.

    1. Download Breakout v.0.3.2 on mac
    2. Change hello world example line: var arduino = new IOBoard(“”, 8887);
    3. Run Breackout Server for mac
    4. Check that it is working fine on mac laptop using Chrome (yes, it’s fine)
    5. Reset server connection (disconnect then connect again)
    6. On Android phone go to, enter laptop IP address
    7. Hit enter on my phone keyboard and nothing happens.

    Am I missing a step?


    In your browser on your phone, open “http://”your-laptop-ip-address:8887/examples”


    The example on appears to be broken (WordPress seems to strip out embedded JS code if updating a template). Try the examples page I referenced above. That works with Safari on iOS and Chrome on Android.


    Thanks for the reply but it still didn’t work. I keep getting timeout errors and the page wouldn’t load. Even with a solid wi-fi connection 🙁

    Were you able to get it working?


    What didn’t work? The examples page? That works for me every time, iOS and Android. Running Breakout Server on OS X 10.10.5.

    Please provide as much information as possible about your setup (phone/tablet OS, computer OS, location of Breakout Server app in relation to the html file you’re trying to run, etc). so I can better understand what is not working.


    These are the steps I am doing:
    1. Connect my windows 10 desktop to wi-fi
    2. Connect my android device (Android 4.1) to the same wi-fi network
    3. Start Breakout Server on my desktop
    4. Refresh the breakout example page on my desktop to make sure it’s working (button input is being read)
    5. Disconnect server and re-connect it to try on my phone this time
    6. On my android phone I open Chrome for mobile and go to http://desktop-ip-address:8887/examples
    7. Page hangs and gives timeout error
    8. I try again on another android device running Android 5.0
    9. Same result as 7.


    I’m able to connect to Breakout Server running on Window 7 Home edition 64-bit (emulated on a Mac). I can connect to a Nexus 5x (Running Stock Android 6.0.1) and an iPad running iOS 9.1. It works even with the firewall enabled.

    Here is a screenshot showing the location of breakout server in relation to the Breakout directory. Also note the Webserver Root Director under the settings tab in Breakout Server. This should point to the Breakout directory to run the examples.


    Here are my firewall settings:


    I also noticed that in Advanced Settings > Inbound Rules, breakout server.exe is listed. Make sure it is listed for you as well. I didn’t do anything manually to get it listed. I assume it gets there by accepting a permission dialog the first time you open the application.

    I’ll try upgrading to Windows 10 later to see if that makes any difference.


    I upgraded to Windows 10 and can still connect to Android and iOS without issue. Make sure breakout server.exe is included in your firewall Inbound Rules. If it is and still doesn’t work I would suspect the issue may be in Android. Version 4.1 may be too old (websockets may not have been supported yet). Android 5.0 should work for sure though unless if you have a non-Nexus device and the manufacturer messed with how sockets work in the OS.

Viewing 9 posts - 1 through 9 (of 9 total)
  • The forum ‘Forum’ is closed to new topics and replies.